简介

最近无聊玩起了思科模拟器,玩着玩着感觉还挺有意思的,就突发奇想想把思科的各种玩法都玩一遍,为了以后方便自己复习,所以水一篇文章

配置好之后记得ping验证连通性

单臂路由

题目:配置路由器,使不同网段的PC1和PC2连通

交换机配置:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
Switch>en
Switch#conf t
Switch(config)#vlan 10 //创建vlan
Switch(config-vlan)#vlan 20 //创建vlan
Switch(config-vlan)#ex //返回
Switch(config)#int f0/1 //进入interface 0/1端口
Switch(config-if)#swit
Switch(config-if)#switchport mode access //将端口模式改为access
Switch(config-if)#switchport access vlan 10 //将端口划分到vlan 10
Switch(config-if)#ex
Switch(config)#int f0/2
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 20
Switch(config-if)#ex
Switch(config)#int f0/3
Switch(config-if)#switchport mode trunk //将端口模式改为trunk
Switch(config-if)#switchport trunk allowed vlan all

路由器配置:

1
2
3
4
5
6
7
8
9
10
11
12
Router>en
Router#conf t
Router(config)#int f0/0
Router(config-if)#no shutdown
Router(config-if)#ex
Router(config)#int f0/0.1
Router(config-subif)#encapsulation dot1Q 10 //封装802.1Q协议给vlan10,下同
Router(config-subif)#ip add 192.168.1.1 255.255.255.0
Router(config-subif)#ex
Router(config)#int f0/0.2
Router(config-subif)#encapsulation dot1Q 20
Router(config-subif)#ip add 192.168.2.1 255.255.255.0

交换机划分vlan

题目:将交换机划分vlan,使两台交换机的财务部、销售部之间可以相互连通,财务部与销售部之间不可连通(ip自设)

交换机SW1配置:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
Switch>en
Switch#conf
Switch(config)#vlan 10
Switch(config-vlan)#vlan 20
Switch(config-vlan)#int f0/1
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 10
Switch(config-if)#ex
Switch(config)#int f0/2
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 20
Switch(config-if)#no shutdown
Switch(config-if)#ex
Switch(config)#int f0/5
Switch(config-if)#switchport mode trunk
Switch(config-if)#switchport trunk allowed vlan 10,20

交换机SW2配置:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
Switch>en
Switch#conf
Switch(config)#vlan 10
Switch(config-vlan)#vlan 20
Switch(config-vlan)#int f0/3
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 10
Switch(config-if)#ex
Switch(config)#int f0/1
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 20
Switch(config-if)#no shutdown
Switch(config-if)#ex
Switch(config)#int f0/5
Switch(config-if)#switchport mode trunk
Switch(config-if)#switchport trunk allowed vlan 10,20
Switch(config-if)#no shutdown
Switch(config-if)#end

配置三层路由器

题目:配置三层交换机(Multilayer_Switch3)使不同网段的PC1和PC2连通

三层交换机配置:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
Switch#en
Switch#conf
Switch(config)#vlan 10
Switch(config-vlan)#vlan 20
Switch(config-vlan)#int f0/1
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 10
Switch(config-if)#ex
Switch(config)#int f0/2
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 20
Switch(config-if)#ex
Switch(config)#int vlan 10
Switch(config-if)#ip add 192.168.1.1 255.255.255.0
Switch(config-if)#no shutdown
Switch(config-if)#ex
Switch(config)#int vlan 20
Switch(config-if)#ip add 192.168.2.1 255.255.255.0
Switch(config-if)#no shutdown
Switch(config)#ip routing //开启三层交换机的路由功能
Switch(config-if)#end
Switch#show ip route

多重静态路由配置

题目:配置静态路由,使PC1、PC2与PC3互相连通

注意:这里还有其他方法可以使PC1、PC2、PC3连通,比如动态路由,想了解的话自己查

R1配置:

1
2
3
4
5
6
7
8
9
10
11
12
Router>en
Router#conf
Router(config)#int f0/0
Router(config-if)#ip ad 192.168.1.1 255.255.255.0
Router(config-if)#no shut
Router(config-if)#ex
Router(config)#int f0/1
Router(config-if)#ip ad 192.168.2.1 255.255.255.0
Router(config-if)#no shut
Router(config-if)#ex
Router(config)#ip route 192.168.3.0 255.255.255.0 192.168.2.2 //ip route 目标网段 子网掩码 经过的第一个非直连网关ip地址
Router(config)#ip route 192.168.4.0 255.255.255.0 192.168.2.2

R2配置:

1
2
3
4
5
6
7
8
9
10
11
12
Router>en
Router#conf
Router(config)#int f0/1
Router(config-if)#ip ad 192.168.2.2 255.255.255.0
Router(config-if)#no shut
Router(config-if)#ex
Router(config)#int f0/0
Router(config-if)#ip add 192.168.3.1 255.255.255.0
Router(config-if)#no shut
Router(config-if)#ex
Router(config)#ip route 192.168.1.0 255.255.255.0 192.168.2.1
Router(config)#ip route 192.168.4.0 255.255.255.0 192.168.3.2

R3配置:

1
2
3
4
5
6
7
8
9
10
11
12
Router>en
Router#conf
Router(config)#int f0/1
Router(config-if)#ip add 192.168.3.2 255.255.255.0
Router(config-if)#no shut
Router(config-if)#ex
Router(config)#int f0/0
Router(config-if)#ip add 192.168.4.1 255.255.255.0
Router(config-if)#no shut
Router(config-if)#ex
Router(config)#ip route 192.168.2.0 255.255.255.0 192.168.3.1
Router(config)#ip route 192.168.1.0 255.255.255.0 192.168.3.1